Добавленная к описанию оповещения переменная (например, {{close}}) не сработала

Функция замены переменной alertcondition() работает только в том случае, если скрипт написан в 4 версии (Pine v4) и выше. Если при срабатывании оповещения плейсхолдер в описании не заменен переменной (например, отображает Close = {{close}} вместо Close = 45.1), индикатор с функцией alertcondition() скорее всего написан в одной из предыдущих версий языка Pine, в которых поддержка переменных еще не добавлена.

Вот как функция работает в версии Pine 4 и выше:

А так функция работает в более ранних версиях Pine:

Так получается при добавлении переменной в диалоговое окно ввода сообщения для оповещений, когда при этом не внесены изменения в код. Если вы добавили переменную, но при срабатывании оповещения ей не присваивается значение, скорее всего индикатор написан в версии Pine 3 или ниже.

Если скрипт ваш, можно использовать наш конвертер и превратить его в версию Pine v4. Больше об этой функции можно прочесть здесь. Если скрипт взят из публичной библиотеки, вы можете связаться с его автором и попросить обновить индикатор до версии Pine v4.

Домой Скринер акций Скринер форекс Скринер криптовалют Экономический календарь О нас Особенности Цены Приведи друга Правила поведения Справочный центр Решения для сайтов и брокеров Виджеты Графики TradingView для сайтов Легкая версия графиков Блог и новости Твиттер
Профиль Настройка профиля Счёт и оплата Ваши друзья Монеты Мои запросы в поддержку Справочный центр Личные сообщения Чат Выйти